1. 程式人生 > >hdu 5908 Abelian Period(暴力 + map優化)

hdu 5908 Abelian Period(暴力 + map優化)

Abelian Period

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 262144/131072 K (Java/Others)

Problem Description
Let S be a number string, and occ(S,x) means the times that number x occurs in S.

i.e. S=(1,2,2,1,3),occ(S,1)=2,occ(S,2)=2,occ(S,3)=1.

String u,w are matched if for each number i, occ(u,i)=occ(w,i) always holds.

i.e. (1,2,2,1,3)≈(1,3,2,1,2).

Let S be a string. An integer k is a full Abelian period of S if S can be partitioned into several continous substrings of length k, and all of these substrings are matched with each other.

Now given a string S, please find all of the numbers k that k is a full Abelian period of S.

Input
The first line of the input contains an integer T(1≤T≤10), denoting the number of test cases.

In each test case, the first line of the input contains an integer n(n≤100000), denoting the length of the string.

The second line of the input contains n integers S1,S2,S3,…,Sn(1≤Si≤n), denoting the elements of the string.

Output
For each test case, print a line with several integers, denoting all of the number k. You should print them in increasing order.

Sample Input
2
6
5 4 4 4 5 4
8
6 5 6 5 6 5 5 6

Sample Output
3 6
2 4 8

把一個長為n的陣列切成i段,這i段都要滿足以下條件:
1.每一段的長度相同;
2.每一段中的某個數字的出現次數要兩兩相同;
求所有可能的切割方案,並輸出每個方案的n / i.

題目本身不難,思路也很耿直,列舉k(1~n的整數),若是n的約數就直接把陣列平均切成k段,判斷每一段各個數字的出現次數是否相等即可,理論上時間複雜度可以過。

然而一開始記錄是開的陣列,由於memset的存在,時間死活壓不下來,最後用map才搞定(事實上使用map也是這道題卡時間的關鍵)。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <map>
#include <cmath>
#define MAX 100010
#define M 100005
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define eps 1e-8

using namespace std;

int arr[M];
map<int, int> cmp, tmp;

int main()
{
    int T, n;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        for(int i = 0; i < n; i++)
            scanf("%d", &arr[i]);
        int i = n, a, k, j;
        for(; i > 0; i--)
        {
            if(n % i)
                continue;
            cmp.clear();
            k = n / i;
            for(j = 0; j < k; j++)
            {
                cmp[arr[j]]++;
            }
            tmp = cmp, a = 0;
            for(; j < n - k + 1; j += k)
            {
                tmp = cmp;
                for(a = j; a < j + k; a++)
                {
                    if(--tmp[arr[a]] < 0)//如果中間有的數字多出來就跳出迴圈
                        break;
                }
                if(tmp[arr[a]] < 0)//同上
                    break;
            }
            if(tmp[arr[a]] && tmp[arr[a]] < 0)//同上,進行下一迴圈
                continue;
            printf("%d", k);
            i--;
            break;
        }
        for(; i > 0; i--)//只是為了保證輸出格式寫成這樣,上下兩段迴圈裡的內容是一樣的。
        {
            if(n % i)
                continue;
            k = n / i;
            cmp.clear();
            for(j = 0; j < k; j++)
            {
                cmp[arr[j]]++;
            }
            tmp = cmp, a = 0;
            for(; j < n - k + 1; j += k)
            {
                tmp = cmp;
                for(a = j; a < j + k; a++)
                {
                    if(--tmp[arr[a]] < 0)
                        break;
                }
                if(tmp[arr[a]] < 0)
                    break;
            }
            if(tmp[arr[a]] && tmp[arr[a]] < 0)
                continue;
            printf(" %d", k);
        }printf("\n");
    }
    return 0;
}

執行結果:
這裡寫圖片描述