1. 程式人生 > >POJ 1328 Radar Installation(貪心)

POJ 1328 Radar Installation(貪心)

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

Source

這道題就是一道貪心題,思路並不難,但是悲催的是WA了5次,居然是因為如果不符合條件時輸出-1時直接輸出了-1,前面沒帶Case。。。。sad。。。害得我把點的排序按點排了一次,又按區間左端點排了一次。。不過事後發現這兩種排序都可以。。 本題貪心思路是把點轉化為在x軸座標上的區間(即能保證覆蓋該小島的雷達所有可能位置的集合),然後按點的順序排也行,按左端點排也行。然後最左邊的依次向右遍歷,如果下一個區間的最左端在上一個雷達的右端,顯然需要放一個新雷達;如果在左端的話,則需要判斷最右端了,如果最右端也在上個雷達左端的話,那麼這個雷達顯然不能覆蓋當前這個小島,需要把雷達位置調整為當前區間的最右端,這樣既能覆蓋之前的也能覆蓋現在的;如果最右端在上個雷達右端,則無需調整也無需放置新雷達。
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
struct node
{
    double zuo, you;
} fei[2100], t;
int cmp(node a, node b)
{
    return a.zuo < b.zuo;
}
int x[2100],y[2100];
int main()
{
    int i, j, n, d, num, flag, s=0;
    double z, p;
    while(scanf("%d%d",&n,&d)!=EOF)
    {
        if(n==0&&d==0) break;
        s++;
        flag=0;
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            if(y[i]>d)
                flag=1;
        }
        if(flag)
            printf("Case %d: -1\n",s);
        else
        {
            for(i=0; i<n; i++)
            {
                z=sqrt(d*d*1.0-y[i]*y[i]*1.0);
                fei[i].zuo=(double)x[i]-z;
                fei[i].you=(double)x[i]+z;
            }
            sort(fei,fei+n,cmp);
            num=0;
            p=-100000000;
            for(i=0; i<n; i++)
            {
                if(fei[i].zuo>p)
                {
                    num++;
                    p=fei[i].you;
                }
                else if(fei[i].you<p)
                {
                    p=fei[i].you;
                }
            }
            printf("Case %d: %d\n",s,num);
        }
    }
    return 0;
}