1. 程式人生 > >HDU 5724 Chess(博弈&狀壓)

HDU 5724 Chess(博弈&狀壓)

題目:
Problem Description
Alice and Bob are playing a special chess game on an n × 20 chessboard. There are several chesses on the chessboard. They can move one chess in one turn. If there are no other chesses on the right adjacent block of the moved chess, move the chess to its right adjacent block. Otherwise, skip over these chesses and move to the right adjacent block of them. Two chesses can’t be placed at one block and no chess can be placed out of the chessboard. When someone can’t move any chess during his/her turn, he/she will lose the game. Alice always take the first turn. Both Alice and Bob will play the game with the best strategy. Alice wants to know if she can win the game.

Input
Multiple test cases.

The first line contains an integer T(T≤100), indicates the number of test cases.

For each test case, the first line contains a single integer n(n≤1000), the number of lines of chessboard.

Then n lines, the first integer of ith line is m(m≤20), indicates the number of chesses on the ith line of the chessboard. Then m integers pj(1≤pj≤20) followed, the position of each chess.

Output
For each test case, output one line of “YES” if Alice can win the game, “NO” otherwise.

Sample Input
2
1
2 19 20
2
1 19
1 18

Sample Output
NO
YES

2016多校第一場的博弈題,作為一個不會狀壓的鶸今天看到題解趕緊滾去學習了下,果然博大精深,比賽時的求sg值的思路有問題所以GG了,結合網上大神思路改了下:

    利用狀壓的思想求出當前狀態的所有後繼狀態並根據他們的sg值確定當前狀態的sg值;

    因為移動後表示狀態的數必然變小所以正向遍歷;

AC程式碼…:

#include <bits/stdc++.h>
#define rep(i,j,k) for (int i = j; i <= k; i++)
using namespace std;
int sg[(1<<20)+100];

int get_sg (int i) {
    int h[25];
    memset(h, 0, sizeof(h));
    int last = -1;
    rep(j, 0, 19) {
        if(!((i>>j)&1)) last = j; //依次找到一個0位置,標記
        else { //找到1位置
            if(last!=-1){
                h[sg[i^(1<<j)^(1<<last)]] = 1; //標記後繼狀態(將標記的0和1互換後的狀態)
            }
        }
    }
    int j = 0;
    while(h[j])
        j++;
    return j;  //統計獲得sg值
}
int main(){
    int t, n, m, x;
    rep(i, 1, (1<<20))
        sg[i] = get_sg(i);
    scanf("%d",&t);
    while(t--){
        scanf("%d", &n);
        int ans = 0;
        rep(i, 1, n) {
            scanf("%d", &m);
            int t=0;
            rep(i, 1, m){
                scanf("%d", &x);
                t ^= 1<<(20-x); //計算當前的狀態
            }
            ans ^= sg[t];
        }
        puts(ans ? "YES" : "NO");
    }
    return 0;
}

太TM菜了,,滾去做題