1. 程式人生 > >HDOJ-1398 Square Coins(母函式/DP)

HDOJ-1398 Square Coins(母函式/DP)

題目描述

Square Coins

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 14544    Accepted Submission(s): 10003


 

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

 

Sample Input

2 10 30 0

 

Sample Output

1 4 27

題目分析

這道題目可以通過母函式或者DP來實現。

(1)母函式的實現方式比較簡單,與模板實現較為類似,這裡直接打表再輸出即可,但是注意資料範圍要稍微開大一點,否則會WA。

(2)動態規劃的實現中只需把問題扔給上一步即可,即當前狀態(湊出n元)是由上一個狀態(湊出了n-i*i元)得來的,只需要把所有的上一個狀態加起來即可。

母函式程式碼實現

#include <iostream>
#include <algorithm>
using namespace std;

int factor[310]={0}, tmp[310]={0};

void pre(){
	int m;
	int money[18] = {0};
	for (int i=0; i<18; i++){
		money[i] = i*i; 
	}	
	fill(factor, factor+310, 1);
	
	for (int i=2; i<=17; i++){
		m = money[i];
		
		for (int j=0; j<=300; j++){//要到300
			for (int k=0; k+j<=300; k+=m){
				tmp[j+k] += factor[j];
			}
		}
		for (int j=0; j<=300; j++){
			factor[j] = tmp[j];
			tmp[j] = 0;
		}
	}
}

int main(){
	int n;
	pre();
	while(cin>>n && n){
		cout<<factor[n]<<endl;
	}
	return 0;
}


動態規劃實現

 

void dp(){
	factor[0] = 1;
	for (int i=1; i<=17; i++){//遍歷17種money
		for (int j=1; j<=300; j++){//雖然是從小到大求解,實際卻是一直在向小數解扔鍋
			if (j - i*i >= 0)
				factor[j] += factor[j-i*i];
		}
	}
}