1. 程式人生 > 其它 >1002 A+B for Polynomials (附測試點3456的坑)

1002 A+B for Polynomials (附測試點3456的坑)

題目:1002 A+B for Polynomials

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: 

N1 aN1 N2 aN2 ... NK aNK

where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1,2,,K) are the exponents and coefficients, respectively. It is given that 1K10,0NK<<N2<N11000.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input:

2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:

3 2 1.5 1 2.9 0 3.2

思路:

1、使用map

2、注意當底數為0的項不需要輸出,當兩個多項式相加結果為0時,直接輸出0就好了。

測試樣例:

1 0 3.2 
1 0 -3.2

 輸出:

0

程式碼:

#include<stdio.h>
#include<iostream>
#include<iomanip>
#include<ios>
#include<map>
using namespace std;
int main(){
    map<int, double> m;
    map<int, double>::reverse_iterator it;
    int k = 2,n,e,count = 0;
    double c;
    for(int i = 0; i < k; i++){
        cin>>n;
        for(int j = 0; j < n; j++){
            cin>>e>>c;
            m[e] += c;
        }
    }
    for(it = m.rbegin(); it != m.rend(); it++){
        if(it->second == 0){
            continue;
        }
        count++;
    }
    cout<<count;
    for(it = m.rbegin(); it != m.rend(); it++){
        if(it->second == 0){
            continue;
        }
        cout<<" "<<it->first<<" ";
        cout<<fixed<<setprecision(1)<<it->second;
    }
    return 0;
}