1. 程式人生 > >poj1837--Balance(dp:天平問題)

poj1837--Balance(dp:天平問題)

%d 左右 different miss print sort memset poj nag

Balance
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 10773 Accepted: 6685

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.

Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.

It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm);

? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values.

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2

Source

field=source&key=Romania+OI+2002" style="text-transform:none; text-decoration:none">Romania OI 2002 給出每一個鉤子的位置。和砝碼的重量,問將砝碼所有掛上時,有幾種平衡的掛法? 這裏有一個天平平衡的概念,轉化為天平的左右的差,假設差是0那麽天平平衡,所以。dp[i][j]代表當掛第i個砝碼時差為j的種類。

避免反復選擇,所以要使用二維的。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <math.h>
using namespace std;
#define maxn 8000
int cc[30] , gg[30] ;
int dp[30][maxn<<1] ;
int main()
{
    int c , g , i , j , k , max1 = 0 , m = 0 ;
    memset(dp,0,sizeof(dp));
    dp[0][maxn] = 1 ;
    scanf("%d %d", &c, &g);
    for(i = 0 ; i < c ; i++)
    {
        scanf("%d", &cc[i]);
        if( abs(cc[i]) > max1 )
            max1 = abs(cc[i]) ;
    }
    for(i = 1 ; i <= g ; i++)
    {
        scanf("%d", &gg[i]);
        m += max1*gg[i] ;
    }
    max1 = m ;
    for(i = 1 ; i <= g ; i++)
    {
        for(j = 0 ; j < c ; j++)
        {
            if( cc[j] > 0 )
            {
                m = gg[i]*cc[j] ;
                for(k = maxn + max1 ; k >= m ; k--)
                    dp[i][k] += dp[i-1][k-m] ;
            }
            else
            {
                m = gg[i]*cc[j] ;
                for(k = m ; k <= maxn+max1 ; k++)
                    dp[i][k] += dp[i-1][k-m] ;
            }
        }
    }
    printf("%d\n", dp[g][maxn]);
    return 0;
}

poj1837--Balance(dp:天平問題)