1. 程式人生 > >cogs 315. [POJ3255] 地磚RoadBlocks

cogs 315. [POJ3255] 地磚RoadBlocks

each push friends void pop conn 我們 對比 tar

315. [POJ3255] 地磚RoadBlocks

★★★ 輸入文件:block.in 輸出文件:block.out 簡單對比
時間限制:1 s 內存限制:128 MB

Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

貝茜搬到了一個小農場去住,但她很享受偶爾回去看看她的一個好朋友。貝茜很喜歡沿途的風景,因此她希望路上走的盡可能慢一些。於是她決定走次短路而不是最短路。

城郊包含R(1<=R<=100,000)條雙向的路,它們分別連接了N(1<=N<=5000)個十字路口(節點),為了方便我們把它們標記為1..N。貝茜從1號節點出發,她的好朋友(目的地)在N號節點。

次短路和最短路可以部分重合,次短路也有可能經過同一條路或同一個節點多次。次短路是長於最短路的路中最短的那一條。當有多個最短路存在時,次短路是其他所有路中最短的那條。

Input

Line 1: Two space-separated integers: N
and R

Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

輸入:

第1行:兩個被空格分開的整數N和R

第2..R+1行:每行包括三個由空格分開的整數A,B和D組成。用來描述連接節點A和節點B之間路徑的長度是D(1<=D<=5000)。

Output

Line 1: The length of the second shortest path between node 1 and node N

輸出:

第一行:一個整數表示從節點1到節點N之間次短路的長度。

Sample Input

4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output

450

Hint

Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

提示:

樣例中由兩條從節點1到節點N的路分別是1->2->4(len=100+200=300(最短路))和1->2->3->4(100+250+100=450(次短路))。

譯byKZFFFFFFFF

思路:次短路板子

#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define MAXN 400000
using namespace std;
struct nond{
    int g,f,to;
    bool operator<(const nond &r) const {
        if(r.f==f)    return r.g<g;
        else return r.f<f;
    }
}tmp,opt;
int n,m,p,s,t,cnt,tot,tot1,tot2;
int dis[MAXN],vis[MAXN],dis2[MAXN],vis2[MAXN];
int to[MAXN],net[MAXN],cap[MAXN],head[MAXN];
int to1[MAXN],net1[MAXN],cap1[MAXN],head1[MAXN];
void add(int u,int v,int w){
    to[++tot]=v;net[tot]=head[u];cap[tot]=w;head[u]=tot;
    to[++tot]=u;net[tot]=head[v];cap[tot]=w;head[v]=tot;
    to1[++tot1]=v;net1[tot1]=head1[u];cap1[tot1]=w;head1[u]=tot1;
    to1[++tot1]=u;net1[tot1]=head1[v];cap1[tot1]=w;head1[v]=tot1;
}
void spfa(int s){
    queue<int>que1;
    for(int i=0;i<=n;i++)    dis[i]=INF;
    que1.push(s);
    vis[s]=1;dis[s]=0;
    while(!que1.empty()){
        int now=que1.front();
        que1.pop();
        vis[now]=0;
        for(int i=head1[now];i;i=net1[i])
            if(dis[to1[i]]>dis[now]+cap1[i]){
                dis[to1[i]]=dis[now]+cap1[i];
                if(!vis[to1[i]]){
                    vis[to1[i]]=1;
                    que1.push(to1[i]);
                }
            }
    }
}
int Astar(int kk){
    priority_queue<nond>que;
    if(s==t)    kk++;
    if(dis[s]==INF)    return -1;
    tmp.g=0;
    tmp.to=s;
    tmp.f=dis[s];
    que.push(tmp);
    while(!que.empty()){
        tmp=que.top();
        que.pop();
        if(tmp.to==t)    cnt++;
        if(cnt==kk)    return tmp.g;
        for(int i=head[tmp.to];i;i=net[i]){
            opt.to=to[i];
            opt.g=tmp.g+cap[i];
            opt.f=opt.g+dis[to[i]];
            que.push(opt);
        }
    }
    return -1;
}
int main(){
    freopen("block.in","r",stdin);
    freopen("block.out","w",stdout);
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++){
        int a,b,c;
        scanf("%d%d%d",&a,&b,&c);
        add(a,b,c);
    }
    s=1;t=n;
    spfa(t);
    for(int i=1;i<=n;i++){
        cnt=0;
        int ans=Astar(i);
        if(ans!=dis[s]){
            printf("%d",ans);
            return 0;
        }
    }
}

cogs 315. [POJ3255] 地磚RoadBlocks