1. 程式人生 > >D - To the Max POJ - 1050 (動態規劃)

D - To the Max POJ - 1050 (動態規劃)

D - To the Max

 POJ - 1050 

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1

8  0 -2

Sample Output

15

題意:給定一個二維陣列序列,求 最大的連續子序列塊;

思路:列舉第i行到第j行,求出第i行到第j行的每一列的和sum[k](第K列的和),即可以把二維問題轉化為一維問題,這時第i行到第j行中的最大子序列塊,即求sum陣列的最大的連續子序列和,假設為ans(i,j),那麼這個題目所求的最大連續子序列塊即max{ans(i,j)}

#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=110;
const int nmax = 23;
const double esp = 1e-9;
const double PI=3.1415926;
int a[N][N],sum[N];
int n;
int solve()  //求sum陣列中的最大連續子序列和
{
    int maxl=-inf;
    int ans=0;
    for(int i=0; i<n; i++)
    {
        ans+=sum[i];
        maxl=max(maxl,ans);
        if(ans<0) 
      /*只有當前面的連續子序列和大於0,
      才對後面的連續子序列有貢獻,否則
      還不如直接斷開前面的連續子序列段,即置0
      */
            ans=0;
    }
    return maxl;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
            {
                scanf("%d",&a[i][j]);
            }
        int maxl=-inf;
        for(int i=0; i<n; i++)
        {
            memset(sum,0,sizeof(sum));
            for(int j=i; j<n; j++)
            {
                for(int k=0; k<n; k++)
                    sum[k]+=a[j][k];  
                  //sum[k]的值為第i行到第j行第k列上的和
                int ans=solve();
                maxl=max(maxl,ans);
            }
        }
        printf("%d\n",maxl);
    }
    return 0;
}