1. 程式人生 > >To the Max POJ 1050(一維序列的變形)

To the Max POJ 1050(一維序列的變形)

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 


0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 


9 2 
-4 1 
-1 8 
and has a sum of 15. 
Input
The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
Output
Output the sum of the maximal sub-rectangle.
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4  1 -1


8  0 -2
Sample Output

15

思路:題目看似是求最大子矩陣,思路和最大公共子序列一樣,a[i][j]代表了前i行的前j列的所有元素的和,然後直接套路,值得注意的是個人習慣,DP題目陣列下標從1開始

可以避免一些麻煩.

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdio>
typedef long long ll;
#define N 105
using namespace std;
int a[N][N];
int main()
{
    int i,j,k,n,t,sum,imax;
    while (scanf("%d",&n)!=EOF)
    {
        memset(a,0,sizeof(a));
        for (i=1;i<=n;++i)
        {
            for (j=1;j<=n;++j)
            {
                scanf("%d",&t);
                a[i][j]=a[i-1][j]+t;
            }
        }
        imax=0;
        for (i=1;i<=n;++i)  //第一行
        {
            for (j=i;j<=n;++j) //第二行
            {
                sum=0;
                for (k=1;k<=n;++k)
                {
                    t=a[j][k]-a[i-1][k];//前j行前k列的和-前i-1行前k列的和
                    sum+=t;
                    if (sum<0) sum=0;
                    if (sum>imax) imax=sum;
                }
            }
        }
        printf("%d\n",imax);
    }
    return 0;
}