1. 程式人生 > >ZOJ - 3872 Beauty of Array dp

ZOJ - 3872 Beauty of Array dp

Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array A.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2

Sample Output

105
21
38

題意:給出n個數字的序列,求所有連續的子序列,不同數字的和。

題解:我們求出每個位置的數會在多少個子序列中出現即可,假設第k個數a[k],他出現的子序列的數量為 k*(n+1-k),但是,有一樣的數,比如對應p(p<k) 的位置a[p]==a[k] ,對應k位置的我們只計算(k-p)*(n+1-k)即可,因為p和p之前的,在計算p的時候已經計算了一遍了,計算p:p*(n+1-p),因此計算k這個位置時,如果把p之前的序列在算上,那麼a[k]在一個序列中就計算兩遍了,所以標記一下當前數前面出現的位置,對於每個

位置k,a[k],計算(i - pre[a[k] ]) * (n + 1 - i) * a[k] 即可

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
#define INF 0x3f3f3f3f
const int N=1e5+10;
int n,pre[N*10]; 
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		ll ans=0,x;
		scanf("%d",&n);
		memset(pre,0,sizeof(pre));
		for(int i=1;i<=n;i++)
		{
			scanf("%d",&x);
			ans+=(ll)x*(i-pre[x])*(n+1-i);
			pre[x]=i;
		}
		printf("%lld\n",ans);
	}
	return 0;
}