1. 程式人生 > >容斥原理(UVA 10325---The Lottery) 解題報告

容斥原理(UVA 10325---The Lottery) 解題報告

題目:

The Sports Association of Bangladesh is in great problem with their latest lottery `Jodi laiga Jai'. There
are so many participants this time that they cannot manage all the numbers. In an urgent meeting they
have decided that they will ignore some numbers. But how they will choose those unlucky numbers!!!
Mr. NondoDulal who is very interested about historic problems proposed a scheme to get free from
this problem.
You may be interested to know how he has got this scheme. Recently he has read the Joseph's
problem.
There are N tickets which are numbered from 1 to N. Mr. Nondo will choose M random numbers
and then he will select those numbers which is divisible by at least one of those M numbers. The
numbers which are not divisible by any of those M numbers will be considered for the lottery.
As you know each number is divisible by 1. So Mr. Nondo will never select 1 as one of those M
numbers. Now given N, M and M random numbers, you have to nd out the number of tickets which
will be considered for the lottery.
Input
Each input set starts with two Integers N (10 N < 231) and M (1 M 15). The next line will
contain M positive integers each of which is not greater than N.
Input is terminated by EOF.
Output
Just print in a line out of N tickets how many will be considered for the lottery.
Sample Input
10 2
2 3
20 2
2 4
Sample Output
3
10

題意:

給定一個數n 再給m個數(m<15) 假設這m個數為 a[0],a[1].....a[m-1];

求1~n中非陣列a的數的倍數的數,就是把1~n中陣列a的數的倍數篩掉,剩下的數的個數就是結果。

暴力跑會超時,利用容斥原理,比如n=10,m=2,a[0]=2,a[1]=3,把1到20中所有2的倍數篩掉,

先令ans=n=20,ans=ans-n/2=10。再把1到20中所有3的倍數篩掉,ans=ans-n/3=4。

那麼現在問題來了,這麼篩選的話會導致2和3的公倍數進行了二次篩選,也就是6,12,18這三個數,

所以要把這三個數加回來,ans=ans+n/(2*3)=7,得出最終結果。以此類推,數的個數為奇數就減,

數的個數為偶數就加,這就是容斥原理。

DFS 解法:

#include <iostream>

#include <cstdio>

#include <cstring>

using namespace std;

typedef long long ll;

ll gcd(ll a,ll b)

{

if(b==0) return a; return gcd(b,a%b);

}

ll lcm(ll a,ll b)

{

return a/gcd(a,b)*b;

}

ll n,m,a[20],ans=0;

void dfs(ll hav,ll cur,ll num)

{

if(hav>n||cur>=m) return ;

for(int i=cur;i<m;i++) //注意區分這裡的i和主函式裡的i 混了就錯了

{

ll temp=lcm(hav,a[i]);

if(num&1) ans=ans-n/temp;

else ans=ans+n/temp;

dfs(temp,i+1,num+1);

}

}

int main()

{

while(cin>>n>>m)

{

memset(a,0,sizeof(a));

for(int i=0;i<m;i++)

cin>>a[i];

ans=n;

for(int i=0;i<m;i++)

{

ans=ans-n/a[i];

dfs(a[i],i+1,2);

}

cout<<ans<<endl;

}

return 0;

}