1. 程式人生 > >搜尋E Find The Multiple POJ - 1426

搜尋E Find The Multiple POJ - 1426

#acm/搜尋

Description

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

如果我沒理解錯的話,這題是說
n是10進位制數,不超過10進位制200。
m是10進位制數,不超過10進位制100位,即 1 m 1 0 100

1 1\leq m\leq10^{100}-1

long long 最大為10進位制19位,20位到100位的m為什麼不用考慮了呢。
考慮的話要用大數,可為啥直接用long long 就過了呢。

不用大數的話需要用G++編譯,如果用C++編譯需要手寫佇列,否則會超時。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
#include <vector>
#include <queue>
#include <map>
#define INF 0x3f3f3f3f
using namespace std;
typedef long long ll;
int n;
ll bfs(ll m){
    queue<ll>que;
    que.push(m);
    while(!que.empty()){
        ll head = que.front();
        que.pop();
        if(!(head % n)) return head;
        que.push(head * 10);
        que.push(head * 10 + 1);
    }
    return -1;
}

int main(){
     while(~scanf("%d", &n), n){
         cout << bfs(1) <<endl;
     }
    return 0;
}