1. 程式人生 > >Find The Multiple POJ

Find The Multiple POJ

E - Find The Multiple

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2 6 19 0

Sample Output

10 100100100100100100 111111111111111111

題意:求n的任意一個倍數m,即m%n=0, m要滿足m的每一位要麼是1要麼0.

思路:這道題可以用深度優先搜尋來做,我們以a=1為頂點開始搜尋。

把a的值更新為a=a*10 ,    dfs(a), 或者a=a*10+1,  dfs(a);如果a%n==0,就往回回溯,或者搜尋的深度大於等於19的話,也要回溯。

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<iostream>
#include<stack>
#include<algorithm>
using namespace std;
const int maxn=100005;
#define LL long long
int vis[maxn];
stack<int>s;
LL flag=0;
LL n;
void dfs(LL a,int t)
{
    if(t>=19)
    return ;
    if(flag)
        return ;
    if(a%n==0)
    {
        flag=1;
        printf("%lld\n",a);
        return ;
    }
    else
    {
        dfs(a*10,t+1);
        dfs(a*10+1,t+1);
    }

}
int main()
{
    while(~scanf("%lld",&n)&&n)
    {
        flag=0;
        dfs(1,0);

    }
    return 0;
}