1. 程式人生 > >HDU1018(Big Number)

HDU1018(Big Number)

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31253    Accepted Submission(s): 14513


Problem Description In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
 
Input Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 10 7
on each line.
 
Output The output contains the number of digits in the factorial of the integers appearing in the input.
 
Sample Input

  
   2 10 20
   
  
 
   
  
 
Sample Output

  
   7 19
   
  
 

題意:給定一個數字n(1 ≤ n ≤ 107

),求n!的十進位制下的位數。


思路:

方法一:用log10()計算位數,暴力。

#include<cstdio>
#include<cmath>
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        double ans = 1;
        for(int i = 1; i <= n; i++){
            ans += log10(i*1.0);
        }
        printf("%d\n",(int)ans);
    }
}


方法二:不知道又從哪裡出來了個公式。

e是自然對數的底數,則

log10(n!) = 1.0/2*log10(2*π*n) + n*log10(n/e) + 1;

#include<cstdio>
#include<cmath>
const double e = 2.71828182, PI = acos(-1.0);
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        double ans = 1.0/2*log10(2*PI*n) + n*log10(n/e) + 1;
        printf("%d\n",(int)ans);
    }
}