1077 Kuchiguse (20 分)
1077 Kuchiguse (20 分)
The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:
-
Itai nyan~ (It hurts, nyan~)
-
Ninjin wa iyada nyan~ (I hate carrots, nyan~)
Now given a few lines spoken by the same character, can you find her Kuchiguse?
Input Specification:
Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.
Output Specification:
For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai
.
Sample Input 1:
3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~
Sample Output 1:
nyan~
Sample Input 2:
3 Itai! Ninjinnwaiyada T_T T_T
Sample Output 2:
nai
求最長公共字尾
水 不過我現在才知道在string s[] 陣列內不能用length
程式碼
#include<bits/stdc++.h>
using namespace std;
int size(string s)
{
int size = s.length();
return size;
}
int main()
{
int n;
cin >> n;
getchar();
string s[105];
int minn = 0x3f3f3f3f;
for(int i = 1; i <= n ; i ++)
{
getline(cin, s[i]);
reverse(s[i].begin(),s[i].end());
minn = min(minn,size(s[i]));
}
int flag = 0;
int cnt = 0;
for(int i = 0 ; i < minn && !flag; i++)
{
char ch = s[1].at(i);
int ans = 1;
for(int j = 2 ; j <= n && !flag; j++)
{
if(ch == s[j][i])
ans++;
else
{
flag = 1;
break;
}
}
if(ans == n)
cnt++;
}
if(!cnt)
cout<<"nai"<<endl;
else
{
string gg = s[1].substr(0,cnt);
reverse(gg.begin(),gg.end());
cout<<gg<<endl;
}
return 0;
}