1. 程式人生 > >HDU 3635 Dragon Balls(帶權並查集!!!)

HDU 3635 Dragon Balls(帶權並查集!!!)

Dragon Balls

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 7926    Accepted Submission(s): 2937  

Problem Description

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 

His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls.  Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100).  For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). Each of the following Q lines contains either a fact or a question as the follow format:   T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different.   Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2 3 3 T 1 2 T 3 2 Q 2 3 4 T 1 2 Q 1 T 1 3 Q 1

Sample Output

Case 1: 2 3 0 Case 2: 2 2 1 3 3 2

Source

題目意思: 給你n個物品,從1到n編號 現在對n有m個操作 T A B 把A所在集合的物品全部移到B所在的集合(移動的物品包括A) Q X 問你X所在集合的編號,x所在集合的結點數量,和x移到的次數

注意: 比如樣例1:1移到2,然後3移到2,因為是移到2,所以集合編號就是2,注意理解 此時Q 1,那麼1所在集合編號就是2,因為是移到2去的,1所在集合的結點數量是3 那麼此時1的移到此時是1

注意理解移動次數陣列

具體參考程式碼

#include<queue>
#include<set>
#include<cstdio>
#include <iostream>
#include<algorithm>
#include<cstring>
#include<cmath>
#include<map>
#include<string>
#include<string.h>
#include<memory>
using namespace std;
#define max_v 10005
#define INF 9999999
int pa[max_v];
int num[max_v];//num[i] i所在集合內含有結點個數
int mov[max_v];//mov[i] i移動的次數
int n,m;
void init()
{
    for(int i=0; i<=n; i++)
    {
        pa[i]=i;
        num[i]=1;
        mov[i]=0;
    }
}
int find_set(int x)
{
    if(pa[x]!=x)
    {
        int t=pa[x];
        pa[x]=find_set(pa[x]);
        mov[x]+=mov[t];//孩子結點的移動次數會與其父親結點移動次數相關
    }
    return pa[x];
}
void union_set(int x,int y)
{
    int fx=find_set(x);
    int fy=find_set(y);

    if(fx!=fy)
    {
        pa[fx]=fy;
        num[fy]+=num[fx];//合併之後大集合的結點數等於原來兩個小集合結點數目之和
        mov[fx]++;//x的根結點 移動次數++ x的移動次數在find_set函式裡面更新
    }
}
int main()
{
    int t;
    int x,y;
    char str[10];
    int c=1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d %d",&n,&m);
        init();
        printf("Case %d:\n",c++);
        for(int i=0; i<m; i++)
        {
            scanf("%s",str);
            if(str[0]=='T')
            {
                scanf("%d %d",&x,&y);
                union_set(x,y);
            }
            else if(str[0]=='Q')
            {
                scanf("%d",&x);
                int k=find_set(x);
                printf("%d %d %d\n",k,num[k],mov[x]);
            }
        }
    }
    return 0;
}
/*
題目意思:
給你n個物品,從1到n編號
現在對n有m個操作
T A B 把A所在集合的物品全部移到B所在的集合(移動的物品包括A)
Q X 問你X所在集合的編號,x所在集合的結點數量,和x移到的次數

注意:
比如樣例1:1移到2,然後3移到2,因為是移到2,所以集合編號就是2,注意理解
此時Q 1,那麼1所在集合編號就是2,因為是移到2去的,1所在集合的結點數量是3
那麼此時1的移到此時是1

注意理解移動次數陣列

具體參考程式碼
*/