1. 程式人生 > >三分法求單峰函式極值

三分法求單峰函式極值

模板,注意精度一般為1e-6,1e-8跟1e-10用的較少。

double three_devide(double l, double r)
{
    double left = l, right = r,mid,midmid;
    while(left + esp < right)
    {
        mid = (left + right)/2;
        midmid = (mid + right)/2;
        if(cal(mid) >= cal(midmid))//根據所有是極大值還是極小值變換。
           right = midmid;
            else
        left = mid;
    }
    return cal(right);

}

Light Bulb


Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.


Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.
Each test case contains three real numbers H, h and D in one line. H is the height of the light bulb while h is the height of mildleopard. D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, and H - h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input


3
2 1 0.5
2 0.5 3
4 3 4


Sample Output


1.000
0.750
4.000

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>


using namespace std;
const double esp = 1e-8;
double H, h, D;
double cal(double x)
{
    return ((h- H)*D/x + H + D - x);
}
double three_devide(double l, double r)
{
    double left = l, right = r,mid,midmid;
    while(left + esp < right)
    {
        mid = (left + right)/2;
        midmid = (mid + right)/2;
        if(cal(mid) >= cal(midmid))//=
           right = midmid;
            else
        left = mid;
    }
    return cal(right);

}

int main()
{
  int t;
  scanf("%d",&t);
  while(t --)
  {
     scanf("%lf %lf %lf", &H, &h, &D);
      double ans = three_devide(D - h*D/H,D);
      printf("%.3f\n", ans);
  }
    return 0;
}