1. 程式人生 > >hdu6441 Find Integer勾股數

hdu6441 Find Integer勾股數

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1666    Accepted Submission(s): 579
Special Judge

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=cn.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1 2 3

Sample Output

4 5

費馬大定理 


1. a^n+b^n=c^n,n>2時無解。 


2. 當a為奇數時, 
a=2⋅k+1

c=k^2+(k+1)^2

b=c−1

當 a為偶數

a=2∗k+2

c=1+(k+1)^2

b=c−2

#include<bits/stdc++.h>
using namespace std;
const int maxn=500100;
typedef long long ll;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,a;
        scanf("%d%d",&n,&a);
        if(n==0||n>2)
        {
            printf("-1 -1\n");
            continue;
        }
        if(n==1)
        {
            printf("1 %lld\n",a+1);
            continue;
        }
        if(a%2)//a是奇數
        {
            int k=(a-1)/2;
            ll b=2*k*k+2*k;
            ll c=b+1;
            printf("%lld %lld\n",b,c);
        }
        else//a偶數
        {
            int k=(a-2)/2;
            ll c=k*k+2*k+2;
            ll b=c-2;
            printf("%lld %lld\n",b,c);
        }
    }
}