1. 程式人生 > >BUY LOW, BUY LOWER----POJ_1952----最長遞減子序列

BUY LOW, BUY LOWER----POJ_1952----最長遞減子序列

BUY LOW, BUY LOWER
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6692 Accepted: 2302

Description

The advice to "buy low" is half the formula to success in the bovine stock market.To be considered a great investor you must also follow this problems' advice: 
                    "Buy low; buy lower"

Each time you buy a stock, you must purchase it at a lower price than the previous time you bought it. The more times you buy at a lower price than before, the better! Your goal is to see how many times you can continue purchasing at ever lower prices. 

You will be given the daily selling prices of a stock (positive 16-bit integers) over a period of time. You can choose to buy stock on any of the days. Each time you choose to buy, the price must be strictly lower than the previous time you bought stock. Write a program which identifies which days you should buy stock in order to maximize the number of times you buy. 

Here is a list of stock prices: 
 Day   1  2  3  4  5  6  7  8  9 10 11 12

Price 68 69 54 64 68 64 70 67 78 62 98 87


The best investor (by this problem, anyway) can buy at most four times if each purchase is lower then the previous purchase. One four day sequence (there might be others) of acceptable buys is: 
Day    2  5  6 10

Price 69 68 64 62

Input

* Line 1: N (1 <= N <= 5000), the number of days for which stock prices are given 

* Lines 2..etc: A series of N space-separated integers, ten per line except the final line which might have fewer integers. 

Output

Two integers on a single line: 
* The length of the longest sequence of decreasing prices 
* The number of sequences that have this length (guaranteed to fit in 31 bits) 

In counting the number of solutions, two potential solutions are considered the same (and would only count as one solution) if they repeat the same string of decreasing prices, that is, if they "look the same" when the successive prices are compared. Thus, two different sequence of "buy" days could produce the same string of decreasing prices and be counted as only a single solution. 

Sample Input

12
68 69 54 64 68 64 70 67 78 62
98 87

Sample Output

4 2

Source

此題的題意就是,在買股票的時候你這次買的股票的價格必須嚴格小於你上一次買的股票。如果你買的次數越多就越好。現在給你若干股票。每天一支。有n天。讓你求出在這個順序下最多能買多少隻股票。除此之外,還要你給出買最長的股票下不同的方案有多少種。如果兩種方案中下降的序列是一樣的話就只能算作一種。現在要給出最長的長度,以及最長長度的不同方案數。用f[i]表示在以第i個結尾的最長遞減子序列的長度,用count[i]表示以第i個結尾時f[i]長度的不同方案數。用data[i]儲存每個的價值。 則狀態轉移方程為:       f[i] = max(f[j]+1)     0<=j<i   && data[j] > data[i]       count[i] = sum(count[j])  0<=j<i && f[i] = f[j]+1 && data[j]>data[i] 需要指出的是 如果f[i] == f[j]  && data[i] == data[j]    則他們在下降子序列的位置是一樣的而且值也一樣,只需要計算它們中的第一個就可以了,其餘的不必計算在內。而且這個事求遞減的子序列,則我們需將data[0]置為一個很大的數,這其它的數相對於它都是遞減的。
#include<iostream>
using namespace std;

#define MAX 5050

long f[MAX]; //f[i]表示以第i個元素作為最後一個字元的最長遞減子序列的長度 
long data[MAX];
long count[MAX];//表示以第i個元素作為最後一個字元且長度為f[i]的是不同的最長遞減子序列的方案數 

int main()
{
	int n;
	while(cin>>n && n)
	{
		int i,j;
		int max = 0;

		for(i=1;i<=n;i++)
		{
			cin>>data[i];
			//賦初值,因為一開始的時候什麼都還沒有,所以賦0 
			f[i] = 0;
			count[i] = 0;
		}
		f[0] = 0;

		//求最大遞減子序列
		data[0] = 999999999;
		for(i=1;i<=n;i++)
		{
			for(j=i-1;j>=0;j--)
				if(data[j] > data[i] && f[j] + 1 > f[i])
					f[i] = f[j] + 1;

			if(max < f[i])//將最長的長度儲存 
				max = f[i];
		}
		//////////////////////////////////////


		//計算數量,也是一個DP,轉換方程為
		//count[i] = all(count[j])  && dp[i] = dp[j]+1 && data[i]<data[j]
		//還要注意去除掉序列中相同位置且資料相同的元素,我採用的是去除的方法
		int Acount = 0;
		count[0] = 1;

		for(i=1;i<=n;i++)
		{
			for(j=i-1;j>=0;j--)
			{
				if(f[i] == f[j] && data[i] == data[j]) //位置和資料一致,則不重複計算
					break;
				if(f[i] == f[j]+1 && data[i] < data[j])
					count[i]+=count[j];
			}
			if(f[i] == max  && count[i])  //達到了最長子序列的長度 
				Acount += count[i];
			//cout<<"----------------"<<endl;
			//cout<<i<<" "<<count[i]<<endl;
		}

		cout<<max<<" "<<Acount<<endl;
	}

	return 0;
}