1. 程式人生 > >HDU3635 Dragon Balls (帶權並查集)

HDU3635 Dragon Balls (帶權並查集)

Five hundred years later, the number of dragon balls will increase unexpectedly, so it's too difficult for Monkey King(WuKong) to gather all of the dragon balls together. 


His country has N cities and there are exactly N dragon balls in the world. At first, for the ith dragon ball, the sacred dragon will puts it in the ith city. Through long years, some cities' dragon ball(s) would be transported to other cities. To save physical strength WuKong plans to take Flying Nimbus Cloud, a magical flying cloud to gather dragon balls. 
Every time WuKong will collect the information of one dragon ball, he will ask you the information of that ball. You must tell him which city the ball is located and how many dragon balls are there in that city, you also need to tell him how many times the ball has been transported so far.

Input

The first line of the input is a single positive integer T(0 < T <= 100). 
For each case, the first line contains two integers: N and Q (2 < N <= 10000 , 2 < Q <= 10000). 
Each of the following Q lines contains either a fact or a question as the follow format: 
  T A B : All the dragon balls which are in the same city with A have been transported to the city the Bth ball in. You can assume that the two cities are different. 
  Q A : WuKong want to know X (the id of the city Ath ball is in), Y (the count of balls in Xth city) and Z (the tranporting times of the Ath ball). (1 <= A, B <= N)

Output

For each test case, output the test case number formated as sample output. Then for each query, output a line with three integers X Y Z saparated by a blank space.

Sample Input

2
3 3
T 1 2
T 3 2
Q 2
3 4
T 1 2
Q 1
T 1 3
Q 1

Sample Output

Case 1:
2 3 0
Case 2:
2 2 1
3 3 2
#include<stdio.h> 
#include<string.h>
#include<algorithm>
using namespace std;
int par[10010],ran[10010],d[10010];
void init(int n)
{
	for(int i=1;i<=n;i++)
	{
		par[i]=i;
		ran[i]=1;//統計集合的個數
		d[i]=0;//通過不斷加父親節點移動的次數統計這個點的移動次數
	}
}
int find(int x)
{
	    
	if(par[x]==x)
	{
		return x;
	}
	else
	{   
	    int r=par[x];
	    par[x]=find(par[x]);
	    d[x]+=d[r];//加上父親節點的移動次數
		return par[x];
	}
}
void unite(int x,int y)
{
    
	x=find(x);
	y=find(y);
	if(x==y) return;
    par[x]=y;
    ran[y]+=ran[x];
    d[x]=1;這個點移動過變為1(為1是因為輸入不可能為環
}
int main()
{
	int n,m;int o=0;int t;
	scanf("%d",&t);
	while(t--)
	{
		memset(d,0,sizeof(d));
		scanf("%d %d",&n,&m);
		init(n);
		printf("Case %d:\n",++o);
		for(int i=0;i<m;i++)
		{
			char e[20];
			scanf("%s",e);
			int a,b;
			
			if(e[0]=='T')
			{
			scanf("%d %d",&a,&b);
				unite(a,b);
			}
			else
			{
				scanf("%d",&a);
				int r=find(a);//d裡的數值在這裡計算的
				printf("%d %d %d\n",r,ran[r],d[a]);
			}
				
		}
	}
	return 0;
}