1. 程式人生 > >HDU 1028 母函式

HDU 1028 母函式

Ignatius and the Princess III

Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"

Input The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.

Output For each test case, you have to output a line contains an integer P which indicate the different equations you have found.

Sample Input 4 10 20
Sample Output 5 42 627


題意:

 4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
這樣說明有五種可以組成4,給你一個數,存在幾個這樣的情況可以組成它。

母函式的應用,現在還不是很熟悉,剛學的..有點迷茫,但還是有點理解了,,

實際上就是就(1+x+x^2+x^3+...)(1+x^2+x^4+x^6+...)(1+x^3+x^6+x^9+...)(1+x^4+x^8+...)........

中x的n次方的係數

用母函式求解,其實就是一個式子一個式子乘進去..記錄各個次方的係數

母函式的經典題目。

#include <iostream>
using namespace std;
int c1[1111],c2[1111];
int mamafun(int n)//母函式
{
	int i,j,k;
	for(i=0;i<=n;i++)
		c1[i]=1,c2[i]=0;//初始化第一個式子(1+x+x^2+x^3+...)
	for(i=2;i<=n;i++)//從第二個才是乘入
	{
		for(j=0;j<=n;j++)
			for(k=0;k+j<=n;k+=i)//k+=i:(1+x+x^2+x^3..)、(1+x^2+x^4..)、(1+x^3+x^6+..)..
				c2[k+j]+=c1[j];
		for(j=0;j<=n;j++)//乘i-th表示式的結果賦值
			c1[j]=c2[j],c2[j]=0;//c2=0,因為c2每次是從一個表示式中開始的
	}
	return c1[n];
}
int main()
{
	int n;
	while(~scanf("%d",&n))
		printf("%d\n",mamafun(n));
	return 0;
}