1. 程式人生 > >貪心——D - Radar Installation

貪心——D - Radar Installation

then 題目 mini minimal 區間 sum bool blank src

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.
技術分享圖片

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1



題目大意:
就是給你n組數據和圓的半徑d,讓你在x軸上畫半徑為d的圓,問:如果將所有的點都畫進去,最少需要多少個圓,這個題目和導彈攔截有點像,不過更加簡單

思路:
就是先判斷d是不是大於等於0,如果d<0,肯定是輸出-1的,
之後輸入數字,如果有坐標的縱坐標比d還要大,那麽也是不對的也要輸出-1
之後對坐標進行處理,把每一個坐標在x軸上的範圍標記出來,並進行排序,先排右邊的位置,右邊位置越小就排在越前面,因為我們是要從橫坐標左邊往右邊排
如果右邊相同,就排左邊,左邊大的先排,因為區間範圍小的肯定可以把區間範圍大的包括進去,反之則不行。
排完序之後
就開始畫圈圈。



#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
using namespace std;
const int maxn=1010;
struct node
{
    double l,r;
}exa[maxn];
bool cmp(node a,node b)
{
    if(a.r==b.r) return a.l>b.l;
    return a.r<b.r;
}

int main()
{
    int n,cnt=0;;
    double d,a,b;
    while(scanf("%d%lf",&n,&d)!=EOF&&(n+d))
    {
        bool flag=0;
        if(d>=0) flag=1;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&a,&b);
            if(b>d) flag=0;
            if(flag)
            {
                exa[i].l=a-sqrt(d*d-b*b);
                exa[i].r=a+sqrt(d*d-b*b);
            }
        }
        sort(exa,exa+n,cmp);
        int ans=-1;
        if(flag)
        {
            ans=1;
            double maxr=exa[0].r;
            for(int i=1;i<n;i++)
            {
                if(exa[i].l>maxr)
                {
                    ans++;
                    maxr=exa[i].r;
                }
            }
        }
        cout << "Case " << ++cnt << ": " << ans << endl;
    }
    return 0;
}

  











貪心——D - Radar Installation