1. 程式人生 > >Ant Counting(多重集組合數)

Ant Counting(多重集組合數)

原體連結

Language:
Ant Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4895 Accepted: 1866
Description

Bessie was poking around the ant hill one day watching the ants march to and fro while gathering food. She realized that many of the ants were siblings, indistinguishable from one another. She also realized the sometimes only one ant would go for food, sometimes a few, and sometimes all of them. This made for a large number of different sets of ants!

Being a bit mathematical, Bessie started wondering. Bessie noted that the hive has T (1 <= T <= 1,000) families of ants which she labeled 1..T (A ants altogether). Each family had some number Ni (1 <= Ni <= 100) of ants.

How many groups of sizes S, S+1, …, B (1 <= S <= B <= A) can be formed?

While observing one group, the set of three ant families was seen as {1, 1, 2, 2, 3}, though rarely in that order. The possible sets of marching ants were:

3 sets with 1 ant: {1} {2} {3}
5 sets with 2 ants: {1,1} {1,2} {1,3} {2,2} {2,3}
5 sets with 3 ants: {1,1,2} {1,1,3} {1,2,2} {1,2,3} {2,2,3}
3 sets with 4 ants: {1,2,2,3} {1,1,2,2} {1,1,2,3}
1 set with 5 ants: {1,1,2,2,3}

Your job is to count the number of possible sets of ants given the data above.
Input

  • Line 1: 4 space-separated integers: T, A, S, and B

  • Lines 2..A+1: Each line contains a single integer that is an ant type present in the hive
    Output

  • Line 1: The number of sets of size S..B (inclusive) that can be created. A set like {1,2} is the same as the set {2,1} and should not be double-counted. Print only the LAST SIX DIGITS of this number, with no leading zeroes or spaces.
    Sample Input

3 5 2 3
1
2
2
1
3
Sample Output

10
Hint

INPUT DETAILS:

Three types of ants (1..3); 5 ants altogether. How many sets of size 2 or size 3 can be made?

OUTPUT DETAILS:

5 sets of ants with two members; 5 more sets of ants with three members

原題就是說有T種螞蟻,每種螞蟻都有各自的數量,不同的螞蟻可以區分,但是同種的螞蟻無法區分,問你一共可以如果看見從B只螞蟻到看見S只螞蟻共可以有多少種可能的情況
用dp[i][j]表示從前i種物品中取出j個的組合總數
那麼明顯dp[i][j]=從k=0到k=min(j,a[i])求和dp[i-1][j-k]是成立的,但是很明顯這樣做是要超時的(0(nm^2)),所以就要對k的列舉進行優化,那麼可以認為每次求組合數的時候是分不算上第i種螞蟻和算上第i種螞蟻,前者是dp[i-1][j],後者就稍微複雜一些,先得出dp[i][j-1]代表第i種螞蟻至少有一個,那麼就需要除去第i種螞蟻被算成有a[i]+1~j這麼多的情況,那麼這就是前i-1種螞蟻被算成1~j-a[i]-1的情況,所以dp狀態轉移方程如下

if(j-1-a[i]>=0)
        dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1]-dp[(i-1)%2][j-a[i]-1] + MOD) % MOD;
else
        dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1])%MOD;

下面附上我的程式碼

#include <algorithm>
#include <iostream>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;

#define MOD 1000000
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
//const LL INFF = 0x3f3f3f3f3f3f3f3fLL;
//const DB EPS = 1e-9;
//const DB OO = 1e20;
//const DB PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=100000 + 10;
int a[1005];//代表每種螞蟻有多少個
int dp[2][maxn];//代表前i中物品中取出j個的組合總數,這裡對i的情況要進行滾動陣列的優化

int main(){
        int T,A,S,B,res=0;
        dp[0][0]=1;dp[1][0]=1;
        scanf("%d%d%d%d",&T,&A,&S,&B);
        for(int i=0;i<A;i++){
                int t;
                scanf("%d",&t);
                a[t]++;
        }
        for(int i=1;i<=T;i++){//i最小也是1了
                for(int j=1;j<=B;j++){
                        if(j-1-a[i]>=0)//在取模時若出現了減法運算則需要先+Mod再對Mod取模,防止出現負數(如5%4-3%4為負數)
                                dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1]-dp[(i-1)%2][j-a[i]-1] + MOD) % MOD;
                        else
                                dp[i%2][j]=(dp[(i-1)%2][j]+dp[i%2][j-1])%MOD;
                }
        }
        for(int j=S;j<=B;j++)
                res = (res + dp[T%2][j])%MOD;//這裡一定要把res加進去再MOD,否則就會出問題
        printf("%d\n",res);
        return 0;
}