UVa 10392 Factoring Large Numbers (素因子分解)
10392 - Factoring Large Numbers
Time limit: 3.000 seconds
One of the central ideas behind much cryptography is that factoring large numbers is computationally intensive. In this context one might use a 100 digit number that was a product of two 50 digit prime numbers. Even with the fastest projected computers this factorization will take hundreds of years.
You don't have those computers available, but if you are clever you can still factor fairly large numbers.
Input
The input will be a sequence of integer values, one per line, terminated by a negative number. The numbers will fit in gcc's long long int
datatype.
You may assume that there will be at most one factor more than 1000000.
Output
Each positive number from the input must be factored and all factors (other than 1) printed out. The factors must be printed in ascending order with 4 leading spaces preceding a left justified number, and followed by a single blank line.
Sample Input
90 1234567891 18991325453139 12745267386521023 -1
Sample Output
2 3 3 5 1234567891 3 3 13 179 271 1381 2423 30971 411522630413
water.
完整程式碼:
/*0.016s*/
#include<cstdio>
#include<cstring>
#include<cmath>
typedef long long LL;
const int maxn = 100000;
LL prime[maxn], c;
bool vis[maxn];
inline void make_prime()
{
LL i, j;
for (i = 2; i < maxn; i++)
if (!vis[i])
{
prime[c++] = i;
for (j = i * i; j < maxn; j += i)
vis[j] = true;
}
}
int main()
{
LL n, i, x;
make_prime();
while (scanf("%lld", &n), ~n)
{
x = sqrt(n);
for (i = 0; prime[i] <= x && i < c;)
{
if (n % prime[i] == 0)
{
printf(" %lld\n", prime[i]);
n /= prime[i];
if (n == 1) break;
}
else ++i;
}
if (n != 1) printf(" %lld\n", n);///there will be at most one factor more than 1000000
putchar('\n');
}
return 0;
}