1. 程式人生 > >poj 2718 搜尋

poj 2718 搜尋

Smallest Difference
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 2679 Accepted: 766

Description

Given a number of distinct decimal digits, you can form one integer by choosing a non-empty subset of these digits and writing them in some order. The remaining digits can be written down in some order to form a second integer. Unless the resulting integer is 0, the integer may not start with the digit 0. 

For example, if you are given the digits 0, 1, 2, 4, 6 and 7, you can write the pair of integers 10 and 2467. Of course, there are many ways to form such pairs of integers: 210 and 764, 204 and 176, etc. The absolute value of the difference between the integers in the last pair is 28, and it turns out that no other pair formed by the rules above can achieve a smaller difference.

Input

The first line of input contains the number of cases to follow. For each case, there is one line of input containing at least two but no more than 10 decimal digits. (The decimal digits are 0, 1, ..., 9.) No digit appears more than once in one line of the input. The digits will appear in increasing order, separated by exactly one blank space.

Output

For each test case, write on a single line the smallest absolute difference of two integers that can be written from the given digits as described by the rules above.

Sample Input

1
0 1 2 4 6 7

Sample Output

28
我本想分情況討論做得,雖然這道題被分在了搜尋裡,但貌似可以暴力的,我這裡為了訓練,練習的是搜尋。這個題剛開始的時候沒想出來,參考的是網上的大牛的思想。哎,弱暴了。
下面是程式碼:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int inf=0x3f3f3f3f;
int a[12],b[12],n,ans;
bool vis[12];

void solve(int aa)
{
    int len=0;
    int bb=0;
    for(int i=0;i<n;i++)
        if(!vis[i])//如果被分割的這個點沒有訪問過
            b[len++]=a[i],bb=bb*10+a[i];//就存入b數組裡
    if(b[0]!=0||len==1)
        ans=min(ans,abs(aa-bb));
    while(next_permutation(b,b+len))//這裡是從開妹那裡學來的,這個stl的含義是才生成從b到b+len的序列的全排列
    {
        bb=0;
        for(int i=0;i<len;i++)//針對每一種排列進行運算,然後比較求出,最小
            bb=bb*10+b[i];
        if(b[0]!=0||len==1)
            ans=min(ans,abs(aa-bb));
    }
}
void dfs(int k,int r)
{
    if(k==n/2)//想要差距最小,位數看就要最接近,所以要對半分
    {
        solve(r);
        return;
    }
    for(int i=0;i<n;i++)
    {
        if(!vis[i])
        {
            if(a[i]==0&&k==0&&n>3)//多位的時候,不允許有前導0
               continue;
            vis[i]=true;
            dfs(k+1,r*10+a[i]);
            vis[i]=false;
        }
    }
}
int main()
{
    int T;
    for(scanf("%d ",&T);T;T--)
    {
        n=0;
        char ch;
        while((ch=getchar())!='\n')
        {
            if(ch==' ')
                continue;
            a[n++]=ch-'0';
        }
        ans=inf;
        memset(vis,false,sizeof(vis));
        dfs(0,0);
        printf("%d\n",ans);
    }
    return 0;
}