1. 程式人生 > >POJ 1088 滑雪 (搜尋)

POJ 1088 滑雪 (搜尋)

Description

Michael喜歡滑雪百這並不奇怪, 因為滑雪的確很刺激。可是為了獲得速度,滑的區域必須向下傾斜,而且當你滑到坡底,你不得不再次走上坡或者等待升降機來載你。Michael想知道載一個區域中最長底滑坡。區域由一個二維陣列給出。陣列的每個數字代表點的高度。下面是一個例子

 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9


一個人可以從某個點滑向上下左右相鄰四個點之一,當且僅當高度減小。在上面的例子中,一條可滑行的滑坡為24-17-16-1。當然25-24-23-...-3-2-1更長。事實上,這是最長的一條。

Input

輸入的第一行表示區域的行數R和列數C(1 <= R,C <= 100)。下面是R行,每行有C個整數,代表高度h,0<=h<=10000。

Output

輸出最長區域的長度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25

 因為有四個方向可以走動,所以需要求出四個方向上的最優解,即四個方向分別遍歷,求出最大的步數。

 從陣列第一個元素開始到最後一個元素進行搜尋。
 程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=105;
int r,c;
int h[maxn][maxn];
int len[maxn][maxn];
int hx,hy;
int Max=-0x3f3f3f3f;
int loc[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int dfs (int x,int y)
{
    if(len[x][y]!=0)
    {
        return len[x][y];
    }
    int step;
    int tx,ty;
    int Maxx=1;
    for (int i=0;i<4;i++)
    {
        tx=x+loc[i][0];
        ty=y+loc[i][1];
        if(tx>0&&tx<=r&&ty>0&&ty<=c&&h[x][y]>h[tx][ty])
        {
            step=dfs(tx,ty)+1;
            Maxx=max(Maxx,step);
        }
    }
    return len[x][y]=Maxx;
}
int main ()
{
    scanf("%d%d",&r,&c);
    for (int i=1;i<=r;i++)
    {
        for (int j=1;j<=c;j++)
        {
            scanf("%d",&h[i][j]);
        }
    }
    memset (len,0,sizeof(len));
    for (int i=1;i<=r;i++)
    {
        for (int j=1;j<=c;j++)
        {
            Max=max(Max,dfs(i,j));
        }
    }
    printf("%d\n",Max);
    return 0;
}