1. 程式人生 > >poj2975 Nim(經典博弈)

poj2975 Nim(經典博弈)

理由 成了 not put blog -a 通過 inner sam

Nim
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5866 Accepted: 2777

Description

Nim is a 2-player game featuring several piles of stones. Players alternate turns, and on his/her turn, a player’s move consists of removing one or more stones from any single pile. Play ends when all the stones have been removed, at which point the last player to have moved is declared the winner. Given a position in Nim, your task is to determine how many winning moves there are in that position.

A position in Nim is called “losing” if the first player to move from that position would lose if both sides played perfectly. A “winning move,” then, is a move that leaves the game in a losing position. There is a famous theorem that classifies all losing positions. Suppose a Nim position contains n

piles having k1, k2, …, kn stones respectively; in such a position, there are k1 + k2 + … + kn possible moves. We write each ki in binary (base 2). Then, the Nim position is losing if and only if, among all the ki’s, there are an even number of 1’s in each digit position. In other words, the Nim position is losing if and only if the xor
of the ki’s is 0.

Consider the position with three piles given by k1 = 7, k2 = 11, and k3 = 13. In binary, these values are as follows:

 111
1011
1101

There are an odd number of 1’s among the rightmost digits, so this position is not losing. However, suppose k3 were changed to be 12. Then, there would be exactly two 1’s in each digit position, and thus, the Nim position would become losing. Since a winning move is any move that leaves the game in a losing position, it follows that removing one stone from the third pile is a winning move when k1 = 7, k2 = 11, and k3 = 13. In fact, there are exactly three winning moves from this position: namely removing one stone from any of the three piles.

Input

The input test file will contain multiple test cases, each of which begins with a line indicating the number of piles, 1 ≤ n ≤ 1000. On the next line, there are n positive integers, 1 ≤ ki ≤ 1, 000, 000, 000, indicating the number of stones in each pile. The end-of-file is marked by a test case with n = 0 and should not be processed.

Output

For each test case, write a single line with an integer indicating the number of winning moves from the given Nim position.

Sample Input

3
7 11 13
2
1000000000 1000000000
0

Sample Output

3
0



簡單博弈,博弈論經典入門:
http://blog.csdn.net/fromatp/article/details/53819565
http://blog.csdn.net/logic_nut/article/details/4711489

/*
如果對自己必勝,則要求對方必輸,而題目給出了必輸的要求就是n堆石子全部異或xor得到XOR,
如果XOR為0,則此狀態必輸。而我們就是要在其中一堆石子中拿取一定量的石頭,使得這個行動過後對手到達必輸點。
我們可以選取其中一堆石頭,減少它的數目後,使得總的異或變成0,而題目就變成了,
到底有那幾堆石頭可以通過拿取一定的石頭使得總的異或變成0.
對於st[i],因為st[i]^st[i]=0。則XOR^st[i]=tmp,根據弋獲性質tmp就是如果第i堆石頭不加入異或時,其他石頭總的異或值。
如果我們可以使得第i堆石頭變成tmp,則全部石頭的異或值就能夠得到0.根據這個理由,只要st[i]>tmp,則第i堆石頭可行。
取大於而不是大於等於,是因為每一局都需要取一顆或以上的石頭。
*/

#include<iostream>
#include<cstdio>
#include<cstring>

#define N 1007

using namespace std;
int st[N],XOR;

int main()
{
    int n,ans;
    while(scanf("%d",&n)&&n)
    {
        for(int i=1;i<=n;i++)
          scanf("%d",&st[i]);
        XOR=0;ans=0;
        for(int i=1;i<=n;i++) XOR^=st[i];
        for(int i=1;i<=n;i++)
        {
            if((XOR^st[i])<st[i]) ans++;
        }
        printf("%d\n",ans);
    }
    return 0;
}



poj2975 Nim(經典博弈)