1. 程式人生 > >poj3070 Fibonacci 矩陣快速冪

poj3070 Fibonacci 矩陣快速冪

Fibonacci

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 19733 Accepted: 13621

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

 

思路:

矩陣快速冪裸題

程式碼:

#include<cstdio>
#include<cstring>
using namespace std;
#define ll long long
#define N 2
const ll mod = 10000;
struct Matrix
{
    int n;
    ll d[N][N];
    void init(int n)
    {
        this -> n = n;
        memset(d,0,sizeof(d));
    }
    Matrix operator *(Matrix b)
    {
        Matrix ans;
        ans.init(n);
        for (int i = 0;i < n;i ++)
            for (int j = 0;j < n;j ++)
                for (int k = 0;k < n;k ++)
                    ans.d[i][j]=(ans.d[i][j]+d[i][k]*b.d[k][j])%mod;
        return ans;
    }
};
ll a[N][N] = {{0,1},
              {1,1}};
Matrix quick(Matrix a,ll b)
{
    Matrix ans;
    ans.init(a.n);
    for (int i = 0;i < ans.n;i ++)
        ans.d[i][i] = 1;
    while (b)
    {
        if (b & 1) ans = ans * a;
        a = a * a;
        b >>= 1;
    }
    return ans;
}
int main()
{
    ll n;
    while (~scanf("%lld",&n) && n != -1)
    {
        if (n < 2)
        {
            printf("%lld\n",n);
            continue;
        }
        Matrix ans,x;
        x.init(2),ans.init(2);
        for (int i = 0;i < N;i ++)
            for (int j = 0;j < N;j ++)
                x.d[i][j] = a[i][j];
        x = quick(x,n - 1);
        ans.d[0][0] = 0,ans.d[0][1] = 1;
        ans = ans * x;
        printf("%lld\n",ans.d[0][1]);
    }
    return 0;
}