1. 程式人生 > >Fibonacci (矩陣快速冪)

Fibonacci (矩陣快速冪)

題目連結
Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is
                                    在這裡插入圖片描述
Given an integer n

, your goal is to compute the last 4 digits of Fn.
Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn

. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

                                             在這裡插入圖片描述

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

                                             在這裡插入圖片描述

程式碼:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
struct matrix{
	long long int mat[2][2];
}A,B;
matrix mul(matrix a,matrix b){
	matrix tmp;
	memset(tmp.mat,0,sizeof(tmp.mat));//注意初始化!!
	for(int i = 0;i < 2;i++)
		for(int j = 0;j < 2;j++)
			for(int k = 0;k < 2;k++)//注意i,j,k的擺放位置
				tmp.mat[i][j] += a.mat[i][k] * b.mat[k][j] % 10000;
	return tmp;
}
matrix pow_mat(matrix a,int n){
	matrix ans;
	for(int i = 0;i < 2;i++)
		for(int j = 0;j < 2;j++)
			i == j ? ans.mat[i][j] = 1 : ans.mat[i][j] = 0;//初始化為單位矩陣
	while(n){
		if(n & 1)
			ans = mul(ans,a);
		a = mul(a,a);
		n >>= 1;
	}
	return ans;
}
int main(){
	long long int n;
	while(~scanf("%lld",&n)){
		if(n == -1)
			break;
		else if(n == 0 || n == 1){
			printf("%lld\n",n);
			continue;
		}
		else{
			A.mat[0][0] = 1,A.mat[0][1] = 0;
			B.mat[0][0] = 1,B.mat[0][1] = 1;
			B.mat[1][0] = 1,B.mat[1][1] = 0;
			B = pow_mat(B,n - 1);
			printf("%lld\n",mul(A,B));
		}
	}
	return 0;
}