1. 程式人生 > >最少轉彎問題

最少轉彎問題

Problem Description

給出一張地圖,這張地圖被分為n*m(n,m<=100)個方塊,任何一個方塊不是平地就是高山。平地可以通過,高山則不能。現在你處在地圖的(x1,y1)這塊平地,問:你至少需要轉幾個彎才能到達目的地(x2,y2)?你只能沿著水平和垂直方向的平地上行進,轉彎次數就等於行進方向的改變(從水平到垂直或從垂直到水平)的次數。

Input

輸入有多組資料,每組資料的第一行為n和m,第2至n+1行為整個地圖地形描述(0:空地;1:高山),第n+2行為起點座標x1,y1,終點座標x2,y2。

Output

對於每組資料輸出最少轉彎次數。

Sample Input

5 7
1 0 0 0 0 1 0
0 0 1 0 1 0 0
0 0 0 0 1 0 1
0 1 1 0 0 0 0
0 0 0 0 1 1 0
1 3 1 7

Sample Output

5
//關鍵字: BFS
//標程:
#include<stdio.h>
#include<queue>
using namespace std;
struct ss
{
int x,y,xx,yy,step;
};
queue<ss> q;
int p[110][110],n,m,x1,x2,y1,y2;
int dir[][2]={1,0,0,1,-1,0,0,-1};
void bfs()
{
     ss ans,temp;
 while(!q.empty())
 {
     temp=q.front();
 if(temp.x==x2 && temp.y==y2) { printf("%d\n",temp.step);   break;}
 q.pop();
 ss newx;
 for(int i=0;i<4;i++)
 {
 newx.x=temp.x+dir[i][0];
 newx.y=temp.y+dir[i][1];
 if((newx.x>=1&&newx.x<=n && newx.y>=1&&newx.y<=m && !p[newx.x][newx.y]) )
{
                    if(newx.x!=temp.xx && newx.y!=temp.yy) newx.step=temp.step+1;
 else  newx.step=temp.step;
   newx.xx=temp.x, newx.yy=temp.y;
q.push(newx);
}
 }
 }
}


int main()
{
//freopen("a.txt","r",stdin);
    while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
scanf("%d",&p[i][j]);
        scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
        while(!q.empty()) q.pop();
ss ans,temp;
temp.x=x1, temp.y=y1, temp.xx=x1, temp.yy=y1, temp.step=0;
q.push(temp);
bfs();
}
return 0;
}