G - Fibonacci Again
阿新 • • 發佈:2019-01-01
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
題意:有一個斐波拉且數列,求是否f[n]能整除3
思路1:由於資料過大,會超出任何型別的表達範圍,所以我用了同餘定理
(a+b) % c = a %c + b % c,能整除的部分已經被我們去除,我們考慮的是不能整除的那部分,從而值不會超出表示範圍
#include<stdio.h> const int maxn = 1000000+1; int f[maxn] = {0}; int main() { int n,i; int flag; f[0] = 7;f[1] = 11; for(i = 2;i <= maxn;++i) //可用(a+b) mod c = a mod c + b mod c { f[i-1] %= 3; f[i-2] %= 3; f[i] = f[i-1]+f[i-2]; } while(scanf("%d",&n)!=EOF) { flag = 0; if(f[n]%3 == 0) flag = 1; if(flag) printf("yes\n"); else printf("no\n"); } return 0; }
思路:從第二項起,每四項輸出結果重複一遍
#include<iostream>
using namespace std;
int main()
{
int n;
while (cin>>n)
{
if ((n - 2) % 4 != 0)
cout << ("no") << endl;
else
cout << ("yes") << endl;
}
return 0;
}