BZOJ 1293 [SCOI2009] 生日禮物 題解與分析
阿新 • • 發佈:2019-02-05
1293: [SCOI2009]生日禮物
Submit: 630 Solved: 326
Input
Output
應包含一行,為最短綵帶長度。Sample Input
6 31 5
2 1 7
3 1 3 8
Sample Output
3HINT
有多種方案可選,其中比較短的是1~5和5~8。後者長度為3最短。
【資料規模】
對於50%的資料, N≤10000;
對於80%的資料, N≤800000;
對於100%的資料,1≤N≤1000000,1≤K≤60,0≤彩珠位置<2^31。
/**************************************************************
Problem: 1293
Language: C++
Result: Accepted
Time:4172 ms
Memory:9192 kb
****************************************************************/
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
#define MAX 61
#define IMAX 2147483647
struct BALL{vector<int> w;};
BALL a[MAX];
int N,K,first[MAX],ans=IMAX,min1=IMAX,max1=0;
int where[MAX];
int num[MAX];
int main()
{
//freopen("input.in","r",stdin);
//freopen("output.out","w",stdout);
scanf("%d%d",&N,&K);
for(int i=1;i<=K;i++)
{
int A;
scanf("%d",&A);
num[i]=A;
for(int j=1;j<=A;j++)
{
int B;
scanf("%d",&B);
a[i].w.push_back(B);
}
where[i]=0;
}
for(int i=1;i<=N-K+1;i++)
{
int use=1;
min1=IMAX,max1=0;
for(int j=1;j<=K;j++)
{
min1=min(min1,a[j].w[where[j]]);
max1=max(max1,a[j].w[where[j]]);
}
ans=min(ans,max1-min1);
min1=IMAX;
for(int j=1;j<=K;j++)
{
if(!(where[j]==num[j]-1) && (a[j].w[where[j]]<min1 || (a[j].w[where[j]]==min1 && a[j].w[where[j]+1]<a[use].w[where[use]+1])))
{
use=j;
min1=a[j].w[where[j]];
}
}
where[use]++;
}
printf("%d\n",ans);
//system("pause");
return 0;
}