Codeforces 892 B. Wrath (遞推)
Description
Hands that shed innocent blood!
There are n guilty people in a line, the i-th of them holds a claw with length Li. The bell rings and every person kills some of people in front of him. All people kill others at the same time. Namely, the i-th person kills the j-th person if and only if j < i and j ≥ i - Li.
You are given lengths of the claws. You need to find the total number of alive people after the bell rings.
Input
The first line contains one integer n (1 ≤ n ≤ 10^6) — the number of guilty people.
Second line contains n space-separated integers L1, L2, …, Ln (0 ≤ Li ≤ 10^9), where Li is the length of the i-th person’s claw.
Output
Print one integer — the total number of alive people after the bell rings.
Examples input
4
0 1 0 10
Examples output
1
題意
每個人都有一個長度為
思路
看完題意,我的心情是這樣的:
顯然,最右側的人一定是可以存活下來的。
我們維護一個
- 若
c 說明當前位置在別人的攻擊範圍內,否則ans+1 。 - 更新
cnt 為max(cnt−1,ai) 看對於i 來說是否可以攻擊到更遠的位置。
時間複雜度
AC 程式碼
#include<bits/stdc++.h>
#define IO ios::sync_with_stdio(false);\
cin.tie(0);\
cout.tie(0);
using namespace std;
typedef __int64 LL;
const int maxn = 2e6+10;
LL a[maxn],n;
void solve()
{
LL cnt = a[n-1],ans = 1;
for(int i=n-2; i>=0; i--)
{
if(!cnt)ans++;
cnt = max(cnt-1,a[i]);
}
cout<<ans<<endl;
}
int main()
{
IO;
cin>>n;
for(int i=0; i<n; i++)
cin>>a[i];
solve();
return 0;
}