Matrix Power Series【矩陣乘法】
Time Limit: 3000MS Memory Limit: 131072K
Total Submissions: 35006 Accepted: 14029
Description
Given a n × n n × n n×n matrix A and a positive integer k, find the sum S = A + A 2 + A 3 + … + A k S = A + A2 + A3 + … + Ak S=A+A2+A3+…+Ak.
Input
The input contains exactly one test case. The first line of input contains three positive integers n (n ≤ 30), k (k ≤ 109) and m (m < 104). Then follow n lines each containing n nonnegative integers below 32,768, giving A’s elements in row-major order.
Output
Output the elements of S modulo m in the same way as A is given.
Sample Input
2 2 4
0 1
1 1
Sample Output
1 2
2 3
題目翻譯
給定一個 n × n n×n n×n矩陣a和一個正整數k,求和 S = a + A 2 + A 3 + … + A k S=a+A2+A3+…+Ak S=a+A2+A3+…+Ak。
輸入
只包含一個測試用例。輸入的第一行包含三個正整數
n
(
n
≤
30
)
、
k
(
k
≤
1
0
9
)
和
m
(
m
<
1
0
4
)
n(n≤30)、k(k≤10^9)和m(m<10^4)
輸出
以與A相同的方式輸出S模m的元素。
解題思路
考慮
1
×
2
1×2
1×2的矩陣
【
A
n
−
1
,
S
[
n
−
2
]
】
【A^n-1,S[n-2]】
【An−1,S[n−2]】,注意此1×2矩陣的2個元素都是r階方陣!我們希望通過乘以某2×2的矩陣M,得到1×2的矩陣
【
A
n
,
S
[
n
−
1
]
】
=
【
A
n
−
1
∗
A
,
A
n
−
1
+
S
[
n
−
2
]
】
【A^n,S[n-1]】=【A^n-1*A, An-1+S[n-2]】
容易構造出此矩陣M為:
其中4個元素均為r階方陣,O表示r階全0矩陣,E表示單位矩陣(主對角線上為1,其它全為0)。
問題解決。我們的複雜度是:
(
2
r
)
3
∗
l
o
g
n
(2r)3*logn
(2r)3∗logn
其實,這個矩陣就是那個流行方法中用到的,這裡我們用前面幾個問題的思想很容易構造出了這個 2 r ∗ 2 r 2r*2r 2r∗2r的矩陣。因此:此思想高效、一般、統一、和諧!
程式碼
#include<algorithm>
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
using namespace std;
long long nn,k,mm;
struct c{
long long n,m;
long long a[100][100];
}A,B,CC;
c operator *(c A,c B){
c C;
C.n=A.n,C.m=B.m;
for(int i=1;i<=C.n;i++)
for(int j=1;j<=C.m;j++)
C.a[i][j]=0;
for(int k=1;k<=A.m;k++)
{
for(int i=1;i<=C.n;i++)
for(int j=1;j<=C.m;j++)
C.a[i][j]=(C.a[i][j]+(A.a[i][k]*B.a[k][j])%mm)%mm;
}
return C;
}
void poww(long long x){
if(x==1)
{
B=A;
return;
}
poww(x>>1);
B=B*B;
if(x&1)
B=B*A;
}
int main(){
scanf("%lld%lld%lld",&nn,&k,&mm);
CC.n=nn,CC.m=2*nn;
A.n=2*nn,A.m=2*nn;
for(int i=1;i<=nn;i++)
for(int j=1;j<=nn;j++)
{
scanf("%lld",&CC.a[i][j]);
CC.a[i][j]=CC.a[i][j]%mm;
A.a[i][j]=CC.a[i][j];
}
for(int i=1;i<=nn;i++)
for(int j=nn+1;j<=2*nn;j++)
if(j-nn==i)
A.a[i][j]=1;
for(int i=nn+1;i<=2*nn;i++)
for(int j=nn+1;j<=2*nn;j++)
if(j==i)
A.a[i][j]=1;
poww(k);
CC=CC*B;
for(int i=1;i<=nn;i++)
{
for(int j=nn+1;j<=2*nn;j++)
printf("%lld ",CC.a[i][j]);
printf("\n");
}
}