1. 程式人生 > >HDU 1260 Tickets (動規)

HDU 1260 Tickets (動規)

app gree nes for each arc sent fine 轉換 dsm

Tickets

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 924 Accepted Submission(s): 468



Problem Description Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help.

Input There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:
1) An integer K(1<=K<=2000) representing the total number of people;
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

Output For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

Sample Input
2
2
20 25
40
1
8

Sample Output
08:00:40 am
08:00:08 am

Source 浙江工業大學第四屆大學生程序設計競賽
Recommend JGShining | We have carefully selected several similar problems for you: 1074 1114

pid=1264" target="_blank">1264

pid=1024" target="_blank">1024 1265

解題思路:

一個人能夠單獨買票花費一定的時間。也能夠兩個人一起買票。也給定一個時間,

給出K個人的單獨買票時間和K-1個相鄰的兩個人一起買票的時間,問一共花費的最小時間。

map[]表示一個人單獨買的時間。v[]表示兩個人一起買的時間。


決策就是,這兩個人是一起買還是分開買。

代碼:0MS

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define M 2050
#define INF 999999
int map[M],v[M],dp[M];
int main()
{
    int i,n,m,t,j,k;
    while(cin>>t)
    {
while(
t--) { cin>>n; for(i=1;i<=n;i++) cin>>map[i]; //單獨買票的時間。 for(i=1;i<=n-1;i++) cin>>v[i]; //一起買票的時間。 for(i=0;i<=n;i++) dp[i]=(i==0?0:INF); dp[1]=map[1]; for(i=2;i<=n;i++) { dp[i]=min(dp[i-1]+map[i],dp[i-2]+v[i-1]); //決策。

} int h = dp[n] / 3600 + 8; //將時間轉換。

int m = dp[n] / 60 % 60; int s = dp[n] % 60; printf("%02d:%02d:%02d am\n", h, m, s); //沒有兩位的補足前到零。 } } return 0; }


HDU 1260 Tickets (動規)