poj1050:to the max
阿新 • • 發佈:2019-01-07
Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.As an example, the maximal sub-rectangle of the array:
0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2
is in the lower left corner:
9 2
-4 1
-1 8
and has a sum of 15.
Input
Output
Sample Input
4 0 -2 -7 0
9 2 -6 2 -4 1 -4 1
-1 8 0 -2
Sample Output
15
這道題實際上是一維最大子序列和的問題在二維矩陣上的擴充套件。回憶一下,最大子序列和是求一維陣列中連續子序列最大和的問題,那麼怎麼向二維擴充套件呢?實際上,子矩陣在兩個方向上也是連續的。所以可以將這二維的問題轉化為一維的,就是可以將子矩陣每一列相加就會得到一個一維的陣列,然後可以用一維最大子序列和的方法來求解。剩下的就是要按行遍歷所有可能的子矩陣,比較找出其中的最大值。當然,思路是別人的,但是,程式碼是自己寫的。
#include <iostream>
#include<cstdlib>
using namespace std;
int maxsubarray(int *a,int n)
{
int maxn=-1;
int sum=0;
for(int i=0;i<n;i++)
{
sum+=a[i];
if(sum>maxn)
maxn=sum;
if(sum<0)
sum=0;
}
return maxn;
}
int tothemax(int a[][101],int n)
{
int t[101];
int maxsum=0,maxn;
for(int i=0;i<n;i++)
for(int j=0;j<=i;j++)
{
for(int k=0;k<n;k++)
{
t[k]=0;
for(int p=j;p<=i;p++)
t[k]+=a[p][k];
}
maxn=maxsubarray(t,n);
if(maxsum<maxn) maxsum=maxn;
}
return maxsum;
}
int main()
{
int i,j,maxsum;
int N;
cin>>N;
int a[101][101];
for(i=0;i<N;i++)
for(j=0;j<N;j++)
cin>>a[i][j];
maxsum=tothemax(a,N);
cout<<maxsum<<endl;
return 0;
}