1. 程式人生 > >POJ 2115 C Looooops(exgcd—解一元線性同餘方程)

POJ 2115 C Looooops(exgcd—解一元線性同餘方程)

C Looooops
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 23820 Accepted: 6591

Description

A Compiler Mystery: We are given a C-language style for loop of type 
for (variable = A; variable != B; variable += C)

  statement;

I.e., a loop which starts by setting variable to value A and while variable is not equal to B, repeats statement followed by increasing the variable by C. We want to know how many times does the statement get executed for particular values of A, B and C, assuming that all arithmetics is calculated in a k-bit unsigned integer type (with values 0 <= x < 2k
) modulo 2k

Input

The input consists of several instances. Each instance is described by a single line with four integers A, B, C, k separated by a single space. The integer k (1 <= k <= 32) is the number of bits of the control variable of the loop and A, B, C (0 <= A, B, C < 2k) are the parameters of the loop. 

The input is finished by a line containing four zeros. 

Output

The output consists of several lines corresponding to the instances on the input. The i-th line contains either the number of executions of the statement in the i-th instance (a single integer number) or the word FOREVER if the loop does not terminate. 

Sample Input

3 3 2 16
3 7 2 16
7 3 2 16
3 4 2 16
0 0 0 0

Sample Output

0
2
32766
FOREVER

題意:對於C的for(i=A ; i!=B ;i +=C)迴圈語句,問在k位儲存系統中迴圈幾次才會結束。若在有限次內結束,則輸出迴圈次數。 否則輸出死迴圈FOREVER。

題解:我們得到同餘方程為 C*x≡(B-A)mod(2^k)。 將a=C,  b=B-A,  m=2^k 得到同餘方程 ax ≡ b mod(m) 。剩下的就是解出這個同餘方程的最小整數解了。

程式碼如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define LL long long

void exgcd(LL a,LL b,LL &d,LL &x,LL &y)
{
	if(!b)
	{
		x=1; y=0;
		d=a;
	}
	else
	{
		exgcd(b,a%b,d,y,x);
		y-=(a/b)*x;
	}
}

int main()
{
	LL A,B,C,k;
	while(scanf("%lld%lld%lld%lld",&A,&B,&C,&k))
	{
		if(A==0&&B==0&&C==0&&k==0)
			break;
		LL a=C,b=B-A,m=(LL)1<<k,x,y,d;
		exgcd(a,m,d,x,y);
		if(b%d)
			printf("FOREVER\n");
		else
		{
			x=(x*(b/d)%(m/d)+(m/d))%(m/d);
			printf("%lld\n",x);
		}
	}	
	return 0;
}