UVa253 Cube painting(骰子塗色)(27行,比較簡潔的樣子)
演算法競賽入門寶典(第2版)習題4-4骰子塗色(Cube painting,UVa253)
Cube painting |
We have a machine for painting cubes. It is supplied with three different colors: blue, red and green. Each face of the cube gets one of these colors.
The cube's faces are numbered as in Figure 1.
Figure 1.
Since a cube has 6 faces, our machine can paint a face-numbered cube in different ways. When ignoring the face
numbers, the number of different paintings is much less, because a cube can be rotated. See example below. We denote a painted cube by a string of 6
characters,where each character is a b
Figure 3 corresponds to rggbgr. Notice that both cubes are painted in the same way: by rotating it around the vertical axis by 90 , t
he one changes into the other.
Input
The input of your program is a textfile that ends with the standard end-of
file marker. Each line is a string of 12 characters. The first 6 characters of this string are the representation of a painted cube, the remaining 6 characters
give you the representation of another cube. Your program determines whether these two cubes are painted in the same way, that is, whether by any
combination of rotations one can be turned into the other. (Reflections are not allowed.)
Output
The output is a file of boolean. For each line of input, output contains TRUE if the second half can be obtained from the first half by rotation
as describes above, FALSEotherwise.
Sample Input
rbgggrrggbgr
rrrbbbrrbbbr
rbgrbgrrrrrg
Sample Output
TRUE
FALSE
FALSE
我的方法
#include <iostream>
#include <string>
using namespace std;
int main()
{
string str,str11,str12,str13,str21,str22,str23;
while(cin>>str){
str11=str[0]+str[5];
str12=str[1]+str[4];
str13=str[2]+str[3];
str21=str[6]+str[11];
str22=str[7]+str[10];
str23=str[8]+str[9];
if((str11==str21||str11==str22||str11==str23)&&
(str12==str21||str12==str22||str12==str23)&&
(str13==str21||str13==str22||str13==str23))
if((str21==str11||str21==str12||str21==str13)&&
(str22==str11||str22==str12||str22==str13)&&
(str23==str11||str23==str12||str23==str13)) //正反都來一次以確保有三個元素組成的可重複集合的單射對映
cout<<"TRUE"<<endl;
else cout<<"FALSE"<<endl;
else cout<<"FALSE"<<endl;
}
return 0;
}
謝謝