算數基本定理 B
Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.
Input
There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.
Output
For each test case there should be single line of output answering the question posed above.
Sample Input
7
12
0
Sample Output
6
4
求解與n(1-n-1)互質的質因子的個數
解析:(轉)
定義:對於正整數n,φ(n)是小於或等於n的正整數中,與n互質的數的數目。
例如:φ(8)=4,因為1,3,5,7均和8互質。
性質:1.若p是質數,φ(p)= p-1.
2.若n是質數p的k次冪,φ(n)=(p-1)*p^(k-1)。因為除了p的倍數都與n互質
3.尤拉函式是積性函式,若m,n互質,φ(mn)= φ(m)φ(n).
根據這3條性質我們就可以推出一個整數的尤拉函式的公式。因為一個數總可以寫成一些質數的乘積的形式。
E(k)=(p1-1)(p2-1)...(pi-1)*(p1^(a1-1))(p2^(a2-1))...(pi^(ai-1))
= k*(p1-1)(p2-1)...(pi-1)/(p1*p2*...*pi)
= k*(1-1/p1)*(1-1/p2)...(1-1/pk)
在程式中利用尤拉函式如下性質,可以快速求出尤拉函式的值(a為N的質因素)
若( N%a ==0&&(N/a)%a ==0)則有:E(N)= E(N/a)*a;
若( N%a ==0&&(N/a)%a !=0)則有:E(N)= E(N/a)*(a-1);
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int oula(int x) // φ(n)=(p-1)*p^(k-1)
{
int ans = 1;
for(int i=2;i*i<=x;i++)
{
if(x%i==0)
{
x/=i; // 這裡為什麼要先除以 i呢?因為 公式裡面是K-1次冪, 在這裡吧那多的一個i除掉
ans = ans*(i-1); //這裡的對應就是公式裡的 p-1
while(x%i==0)
{
x/=i;
ans =ans *i;
}
}
}
if(x>1)
ans = ans*(x-1);
return ans;
}
int main()
{
int n;
while(scanf("%d",&n))
{
if(n==0)break;
printf("%d\n",oula(n));
}
return 0;
}