hdoj——2084數塔
阿新 • • 發佈:2019-02-01
在講述DP演算法的時候,一個經典的例子就是數塔問題,它是這樣描述的:
有如下所示的數塔,要求從頂層走到底層,若每一步只能走到相鄰的結點,則經過的結點的數字之和最大是多少?
已經告訴你了,這是個DP的題目,你能AC嗎?
Input
輸入資料首先包括一個整數C,表示測試例項的個數,每個測試例項的第一行是一個整數N(1 <= N <= 100),表示數塔的高度,接下來用N行數字表示數塔,其中第i行有個i個整數,且所有的整數均在區間[0,99]內。
Output
對於每個測試例項,輸出可能得到的最大和,每個例項的輸出佔一行。
Sample Input
1
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
初學動態規劃,水題練手
思路:
開一個和a陣列同樣大小的dp陣列,記錄當前位置的到塔底所能達到的最大值
即dp[line][row]代表第line行第row列到塔底最優路線的值
在DP函式中不斷呼叫自己以求得每個狀態的值,一旦某個狀態被求出,立即記錄,以免下一次重複的求解
程式碼:
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<list>
#include<iterator>
#include<stack>
#include <queue>
#include <cstdio>
//#include<algorithm>
#pragma warning(disable:4996)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define e 2.718281828459
#define INF 0x7fffffff
#define sf scanf
#define pf printf
#define sf2d(x,y) scanf("%d %d",&(x),&(y))
#define sfd(x) scanf("%d",&x)
#define sff(p) scanf("%lf",&p)
#define pfd(x) printf("%d\n",x)
#define mset(x,b) memset((x),b,sizeof(x))
const double pi = acos(-1.0);
const double eps = 1e-9;
int a[102][102];
int dp[102][102];
int n;
int DP(int line,int row) {
if (dp[line][row] != -1)
return dp[line][row];
dp[line][row]=a[line][row] + max(DP(line + 1,row), DP(line + 1,row + 1));
return dp[line][row];
}
int main(void) {
int c;
sfd(c);
while (c--) {
mset(dp, -1);
sfd(n);
for(int i = 1; i <= n;i++)
for (int j = 1; j <= i; j++) {
sfd(a[i][j]);
}
for (int i = 1; i <= n; i++) {
dp[n][i] = a[n][i];
}
DP(1,1);
pfd(dp[1][1]);
}
return 0;
}
此解法佔用空間較大,思考一下,其實a陣列只用來儲存數值太浪費了,可以把a陣列直接當dp陣列使用,直接在a陣列上操作
程式碼如下:
#include<iostream>
#include<string>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<list>
#include<iterator>
#include<stack>
#include <queue>
#include <cstdio>
//#include<algorithm>
#pragma warning(disable:4996)
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
#define e 2.718281828459
#define INF 0x7fffffff
#define sf scanf
#define pf printf
#define sf2d(x,y) scanf("%d %d",&(x),&(y))
#define sfd(x) scanf("%d",&x)
#define sff(p) scanf("%lf",&p)
#define pfd(x) printf("%d\n",x)
#define mset(x,b) memset((x),b,sizeof(x))
const double pi = acos(-1.0);
const double eps = 1e-9;
int a[102][102];
int n;
int main(void) {
int c;
sfd(c);
while (c--) {
sfd(n);
for(int i = 1; i <= n;i++)
for (int j = 1; j <= i; j++) {
sfd(a[i][j]);
}
for (int i = n-1; i > 0; i--) {//從底層開始往上加,每個狀態選擇其左下角和右下角大的那個加在自身
for (int j = 1; j <=i; j++) {
a[i][j] += max(a[i + 1][j], a[i + 1][j + 1]);
}
}
pfd(a[1][1]);
}
return 0;
}