1. 程式人生 > >HDU 2050:折線分割平面

HDU 2050:折線分割平面

折線分割平面

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36918    Accepted Submission(s): 24732

Problem Description

我們看到過很多直線分割平面的題目,今天的這個題目稍微有些變化,我們要求的是n條折線分割平面的最大數目。比如,一條折線可以將平面分成兩部分,兩條折線最多可以將平面分成7部分,具體如下所示。

Input

輸入資料的第一行是一個整數C,表示測試例項的個數,然後是C 行資料,每行包含一個整數n(0<n<=10000),表示折線的數量。

Output

對於每個測試例項,請輸出平面的最大分割數,每個例項的輸出佔一行。

Sample Input
 

2
1
2

Sample Output

2
7

分割平面數=交點數 + 頂點數 + 1

每增加一條折線,頂點數增加1,交點數增加4*(n-1)。即a(n)=a(n-1)+4*(n-1)+1

#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <math.h>
#include <limits.h>
#include <map>
#define ll long long
#define INF 0x3f3f3f3f
const int maxn=1e4+10;
int a[maxn];
int main(int argc, char const *argv[])
{
	a[1]=2;
	for(int i=2;i<maxn;i++)
	{
		a[i]=a[i-1]+4*(i-1)+1;
	} 
	int n;
	int t;
	std::cin>>t;
	while(t--)
	{
		std::cin>>n;
		std::cout<<a[n]<<std::endl;
	}
	return 0;
}