1. 程式人生 > >poj 1088 滑雪 (記憶化搜尋)

poj 1088 滑雪 (記憶化搜尋)

滑雪

Description

Michael喜歡滑雪百這並不奇怪, 因為滑雪的確很刺激。可是為了獲得速度,滑的區域必須向下傾斜,而且當你滑到坡底,你不得不再次走上坡或者等待升降機來載你。Michael想知道載一個區域中最長底滑坡。區域由一個二維陣列給出。陣列的每個數字代表點的高度。下面是一個例子 
 1  2  3  4 5

16 17 18 19 6

15 24 25 20 7

14 23 22 21 8

13 12 11 10 9

一個人可以從某個點滑向上下左右相鄰四個點之一,當且僅當高度減小。在上面的例子中,一條可滑行的滑坡為24-17-16-1。當然25-24-23-...-3-2-1更長。事實上,這是最長的一條。

Input

輸入的第一行表示區域的行數R和列數C(1 <= R,C <= 100)。下面是R行,每行有C個整數,代表高度h,0<=h<=10000。

Output

輸出最長區域的長度。

Sample Input

5 5
1 2 3 4 5
16 17 18 19 6
15 24 25 20 7
14 23 22 21 8
13 12 11 10 9

Sample Output

25
我們來需要一個數組M來儲存每一個點作為起點的最長長度。然後開始DFS,注意到首先如果搜尋到-1或者此點的高度比上一個點大,就回溯,因為滑雪要從高的地方到低的地方,還有就是如果M[][]如果比-1大了,證明搜尋過這個點了,因為這個點的長度怎麼說也比0大吧,而且我們開始把M初始化為-1了。然後開始dp
也就是座標為x, y的點的長度是其四周的點的長度+1;
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;
typedef long long LL;

#define N 105
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-5
#define met(a, b) memset (a, b, sizeof (a))

const int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};

int dp[N][N], M[N][N], n, m, ans;

int DFS (int x, int y)
{
    int ans = 0;
    if (M[x][y] != -1) return M[x][y];

    for (int i=0; i<4; i++)
    {
        int xx = x + dir[i][0];
        int yy = y + dir[i][1];

        if (xx>0 && xx<=n && yy>0 && yy<=m && dp[xx][yy] > dp[x][y])
            ans = max (ans, DFS (xx, yy));
    }
    M[x][y] = ans + 1;
    return ans+1;
}

int main ()
{
    while (scanf ("%d %d", &n, &m) != EOF)
    {
        int maxn = 0;
        met (M, -1);
        met (dp, 0);

        for (int i=1; i<=n; i++)
        for (int j=1; j<=m; j++)
        scanf ("%d", &dp[i][j]);

        for (int i=1; i<=n; i++)
        for (int j=1; j<=m; j++)
            maxn = max (maxn, DFS (i, j));

        printf ("%d\n", maxn);
    }
    return 0;
}