1. 程式人生 > >hdu1028 整數劃分

hdu1028 整數劃分

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21096    Accepted Submission(s): 14720


Problem Description "Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input 4 10 20 Sample Output 5 42 627 經典題,遞推遞迴。 首先,我們引進一個小小概念來方便描述吧,record[n][m]是把自然數劃劃分成所有元素不大於m的分法,例如: 當n=4,m=1時,要求所有的元素都比m小,所以劃分法只有1種:{1,1,1,1}; 當n=4,m=2時,。。。。。。。。。。。。。。。。只有3種{1,1,1,1},{2,1,1},{2,2}; 當n=4,m=3時,。。。。。。。。。。。。。。。。只有4種{1,1,1,1},{2,1,1},{2,2},{3,1}; 當n=4,m=5時,。。。。。。。。。。。。。。。。只有5種{1,1,1,1},{2,1,1},{2,2},{3,1},{4}; 從上面我們可以發現:當n==1||m==1時,只有一種分法; 當n<m時,由於分法不可能出現負數,所以record[n][m]=record[n][n]; 當n==m時,那麼就得分析是否要分出m這一個數,如果要分那就只有一種{m},要是不分,那就是把n分成不大於m-1的若干份;即record[n][n]=1+record[n][n-1]; 當n>m時,那麼就得分析是否要分出m這一個數,如果要分那就{{m},{x1,x2,x3..}}時n-m的分法record[n-m][m],要是不分,那就是把n分成不大於m-1的若干份;即record[n][n]=record[n-m][m]+record[n][m-1]; 那麼其遞迴式: //dp[i][j]將整數i劃分為最大不超過j的
程式碼實現
import java.util.Scanner;

public class hdu1028 {

	/**
	 * @param args
	 */
	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner scan=new Scanner(System.in);
		int n;
		int record[][]=new int[120+5][120+5];
		while(scan.hasNextInt()){
			n=scan.nextInt();
			for(int i=1;i<=n;i++){
				for(int j=1;j<=n;j++){
					if(i==1||j==1){
						record[i][j]=1;
					}else if(i<j){
						record[i][j]=record[i][i];
					}else if(i==j){
						record[i][j]=1+record[i][j-1];
					}else if(i>j){
						record[i][j]=record[i-j][j]+record[i][j-1];
					}
				}
			}
			System.out.println(record[n][n]);
		}
		
	}

}